Ubuntu Not Using Reserved IP on Windows DHCP Server

I have a couple Ubuntu Server VMs and they never pickup the reserved DHCP address after a reboot. DHCP server is running Windows. Reservation is set using the Ubuntu’s MAC address. A dhclient -r & dhclient will pick up the IP. After a reboot, it’s leased a new IP and the unique ID is a 36 character length string instead of MAC address.

Any suggestions?

Use static a static IP? :slight_smile:

Gonna have to set it static. I found this thread that discusses the issue. Setting the identifier to hardware didn’t fix the issue though. Damn Microsoft…